The following warnings occurred:
Warning [2] Undefined array key "lockoutexpiry" - Line: 94 - File: global.php PHP 8.0.2 (Linux)
File Line Function
/global.php 94 errorHandler->error
/showthread.php 28 require_once
Warning [2] Undefined array key "lockoutexpiry" - Line: 573 - File: global.php PHP 8.0.2 (Linux)
File Line Function
/global.php 573 errorHandler->error
/showthread.php 28 require_once
Warning [2] Undefined variable $can_access_moderationqueue - Line: 752 - File: global.php PHP 8.0.2 (Linux)
File Line Function
/global.php 752 errorHandler->error
/showthread.php 28 require_once
Warning [2] Undefined array key "avatartype" - Line: 892 - File: global.php PHP 8.0.2 (Linux)
File Line Function
/global.php 892 errorHandler->error
/showthread.php 28 require_once
Warning [2] Undefined array key "avatartype" - Line: 892 - File: global.php PHP 8.0.2 (Linux)
File Line Function
/global.php 892 errorHandler->error
/showthread.php 28 require_once
Warning [2] Undefined variable $awaitingusers - Line: 34 - File: global.php(959) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/global.php(959) : eval()'d code 34 errorHandler->error
/global.php 959 eval
/showthread.php 28 require_once
Warning [2] Undefined array key "style" - Line: 1024 - File: global.php PHP 8.0.2 (Linux)
File Line Function
/global.php 1024 errorHandler->error
/showthread.php 28 require_once
Warning [2] Undefined property: MyLanguage::$lang_select_default - Line: 5327 - File: inc/functions.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions.php 5327 errorHandler->error
/global.php 1024 build_theme_select
/showthread.php 28 require_once
Warning [2] Undefined array key 1 - Line: 1474 - File: inc/functions.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions.php 1474 errorHandler->error
/inc/functions.php 1439 fetch_forum_permissions
/inc/functions.php 3077 forum_permissions
/showthread.php 661 build_forum_jump
Warning [2] Undefined array key 1 - Line: 1474 - File: inc/functions.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions.php 1474 errorHandler->error
/inc/functions.php 1439 fetch_forum_permissions
/inc/functions.php 3077 forum_permissions
/showthread.php 661 build_forum_jump
Warning [2] Undefined array key 1 - Line: 1474 - File: inc/functions.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions.php 1474 errorHandler->error
/inc/functions.php 1439 fetch_forum_permissions
/inc/functions.php 3077 forum_permissions
/showthread.php 661 build_forum_jump
Warning [2] Undefined array key "mybb" - Line: 2121 - File: inc/functions.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions.php 2121 errorHandler->error
/inc/functions_indicators.php 41 my_set_array_cookie
/showthread.php 669 mark_thread_read
Warning [2] Undefined array key "profilefield" - Line: 6 - File: inc/functions_post.php(484) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php(484) : eval()'d code 6 errorHandler->error
/inc/functions_post.php 484 eval
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showimages" - Line: 768 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 768 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showvideos" - Line: 773 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 773 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "profilefield" - Line: 6 - File: inc/functions_post.php(484) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php(484) : eval()'d code 6 errorHandler->error
/inc/functions_post.php 484 eval
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showimages" - Line: 768 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 768 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showvideos" - Line: 773 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 773 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "profilefield" - Line: 6 - File: inc/functions_post.php(484) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php(484) : eval()'d code 6 errorHandler->error
/inc/functions_post.php 484 eval
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showimages" - Line: 768 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 768 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showvideos" - Line: 773 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 773 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "profilefield" - Line: 6 - File: inc/functions_post.php(484) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php(484) : eval()'d code 6 errorHandler->error
/inc/functions_post.php 484 eval
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showimages" - Line: 768 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 768 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showvideos" - Line: 773 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 773 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "profilefield" - Line: 6 - File: inc/functions_post.php(484) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php(484) : eval()'d code 6 errorHandler->error
/inc/functions_post.php 484 eval
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showimages" - Line: 768 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 768 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showvideos" - Line: 773 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 773 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "profilefield" - Line: 6 - File: inc/functions_post.php(484) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php(484) : eval()'d code 6 errorHandler->error
/inc/functions_post.php 484 eval
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showimages" - Line: 768 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 768 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showvideos" - Line: 773 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 773 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "profilefield" - Line: 6 - File: inc/functions_post.php(484) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php(484) : eval()'d code 6 errorHandler->error
/inc/functions_post.php 484 eval
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showimages" - Line: 768 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 768 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showvideos" - Line: 773 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 773 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "profilefield" - Line: 6 - File: inc/functions_post.php(484) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php(484) : eval()'d code 6 errorHandler->error
/inc/functions_post.php 484 eval
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showimages" - Line: 768 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 768 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showvideos" - Line: 773 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 773 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "profilefield" - Line: 6 - File: inc/functions_post.php(484) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php(484) : eval()'d code 6 errorHandler->error
/inc/functions_post.php 484 eval
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showimages" - Line: 768 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 768 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showvideos" - Line: 773 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 773 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "profilefield" - Line: 6 - File: inc/functions_post.php(484) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php(484) : eval()'d code 6 errorHandler->error
/inc/functions_post.php 484 eval
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showimages" - Line: 768 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 768 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "showvideos" - Line: 773 - File: inc/functions_post.php PHP 8.0.2 (Linux)
File Line Function
/inc/functions_post.php 773 errorHandler->error
/showthread.php 1126 build_postbit
Warning [2] Undefined array key "invisible" - Line: 1568 - File: showthread.php PHP 8.0.2 (Linux)
File Line Function
/showthread.php 1568 errorHandler->error
Warning [2] Undefined variable $threadnotesbox - Line: 33 - File: showthread.php(1600) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/showthread.php(1600) : eval()'d code 33 errorHandler->error
/showthread.php 1600 eval
Warning [2] Undefined variable $addremovesubscription - Line: 82 - File: showthread.php(1600) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/showthread.php(1600) : eval()'d code 82 errorHandler->error
/showthread.php 1600 eval
Warning [2] Undefined variable $thread_deleted - Line: 104 - File: showthread.php(1600) : eval()'d code PHP 8.0.2 (Linux)
File Line Function
/showthread.php(1600) : eval()'d code 104 errorHandler->error
/showthread.php 1600 eval




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Golem Bot Crashe's! Help!!!
#11
The bot crashes in 1.5.7 iNk at random times, I tried the manual relogin and it crashes, whereas on 1.5.6 previous version I noticed that the bot does not crash but at random times goes to the login page...which in other way is also not good since the bot is stopped...so now in the newer version 1.5.7 as I said we are at the same place of bot crashing at random times...
Reply
#12
Deactivate AuoReconnect and tell me if that fixes the random crash / random relogin for you
Reply
#13
This is what log is saying when autoreconnect is enabled (it did not crash but rather send me to the login page else if autoreconnect would have been disabled then it would have crashed)
2015-05-22 08:29:36: <info> Moving to box 9903|8121, distance: 339.
2015-05-22 08:29:36: <info> Moving to box 9903|8121, distance: 223.
2015-05-22 08:29:37: <info> Collecting box.
2015-05-22 08:29:38: <info> Reconnecting...
2015-05-22 08:29:38: <info> Proceeding with a relogin...
2015-05-22 08:29:39: <info> Moving to box 10204|7939, distance: 351.
2015-05-22 08:29:39: <info> Loading http://darkorbit.bigpoint.com
2015-05-22 08:29:44: <info> Lost connection to the Gameserver! Deadline till reconnect: 15
Reply
#14
In fact, the message "Lost connection to the Gameserver [...]" shouldn't appear with autoReconnect disabled.
Deactivate the option, restart the bot and try it again
Reply
#15
ok iNk Im running the bot without autoreconnect but sometimes I don't understand on space map I press login, it crashes and sometimes not...anyways I will update it as soon as I face a crash..
Reply
#16
This is sad that I left the bot running for 3 hours and when I came back I see that it only ran for 20 minutes and it was standing on login page...there was no crash. and the log says this in the last:

2015-05-22 13:58:04: <info> Collecting box.
2015-05-22 13:58:05: <info> Moving to box 10707|5994, distance: 358.
2015-05-22 13:58:06: <info> Collecting box.
2015-05-22 13:58:08: <info> Randomly moving...
2015-05-22 13:58:09: <info> Moving to box 11452|6380, distance: 391.
2015-05-22 13:58:09: <info> Collecting box.
2015-05-22 13:58:11: <info> Randomly moving...
2015-05-22 13:58:12: <info> Fleeing to closest gate...
2015-05-22 13:58:32: <info> I recognized my own death.
2015-05-22 13:58:32: <info> Reviving...
2015-05-22 13:58:47: <info> Lost connection to the Gameserver! Deadline till reconnect: 15 min
2015-05-22 13:58:47: <info> Connected to the Gameserver!
2015-05-22 13:58:48: <info> Connection to the Gameserver established: Reconnector stopped.
2015-05-22 13:58:48: <info> Pending reconnect stopped.
2015-05-22 14:13:51: <info> Lost connection to the Gameserver! Deadline till reconnect: 15 min
2015-05-22 14:28:55: <info> Reconnecting...

should I give it one more test try?
Reply
#17
I'd like to know what happened reviving and reconnecting.. Did it just stand on the map or what?
Reply
#18
Yes when I relogged it was already repaired and was standing on the map...again I ran it all night and to my surprise it ran fine for 4 hours without any crash but it was standing on the login page...It would have still operated but I guess this is only happening when ship is getting killed and auto reviving, It means that random crashes and random login is fixed but this is only now happening when auto reviving...the log again said this in the last...

2015-05-22 21:03:53: <info> Collecting box.
2015-05-22 21:03:55: <info> Moving to box 12588|5881, distance: 434.
2015-05-22 21:03:55: <info> Moving to box 12588|5881, distance: 320.
2015-05-22 21:03:56: <info> Collecting box.
2015-05-22 21:03:57: <info> Fleeing to closest gate...
2015-05-22 21:04:11: <info> I recognized my own death.
2015-05-22 21:04:11: <info> Reviving...
2015-05-22 21:04:18: <info> Lost connection to the Gameserver! Deadline till reconnect: 15 min
2015-05-22 21:04:18: <info> Connected to the Gameserver!
2015-05-22 21:04:19: <info> Connection to the Gameserver established: Reconnector stopped.
2015-05-22 21:04:19: <info> Pending reconnect stopped.
2015-05-22 21:19:24: <info> Lost connection to the Gameserver! Deadline till reconnect: 15 min
2015-05-22 21:34:29: <info> Reconnecting...
2015-05-22 21:34:29: <info> Proceeding with a relogin...
2015-05-22 21:34:29: <info> Pending reconnect stopped.
2015-05-22 21:34:30: <info> Loading http://darkorbit.bigpoint.com

I don't understand, according to log it revives and also connects to the gameserver but then why does it disconnect? does it not give the time for the ship to repair? maybe set a function for it to jump through the nearest portal and comeback after reviving instead of waiting at the spot to repair because mainly it uses the uri option which revives it at the same spot where it was killed...so give it a function to repair at the portal I guess? well its upto you iNk but I see the problem occurs only after it auto revives...I am testing it with auto-reconnect unticked now till you reply...Thank you anyway for your efforts iNk, you have till now solved many of my problems and corporating very nicely.
Reply
#19
ok so I tried with auto disconnect disabled and just for sake of testing ran it on battle maps and got popped, it selected free repair and I appeared on 2-1 then it repaired and started collecting boxes on 2-1 wtf...i can't collect boxes on 2-1, anyways last time I was testing on 2-8 but unfortunately over there it was selecting the 300 uri option which was reviving it on the spot, so do you think there is something buggy with the uri repair options because with free repair except that it sends the player to company station if in lowers or to uppers one (but uppers is fine it can bot on 2-8 till you add the work map function) everything is fine, check the log:

2015-05-23 02:31:27: <info> Trying to jump now.
2015-05-23 02:31:27: <info> Jumping through gate...
2015-05-23 02:31:33: <info> I recognized my own death.
2015-05-23 02:31:33: <info> Reviving...
2015-05-23 02:31:35: <info> Connected to the Gameserver!
2015-05-23 02:31:44: <info> Successfully revived ship.
2015-05-23 02:31:44: <info> Repair started.
2015-05-23 02:33:04: <info> Hitpoints restored
2015-05-23 02:33:04: <info> Randomly moving...

I see previously this successfully revived ship command was not coming and repair started command was not coming...so I will test more to see if it revives with uri options and problems are occuring or not...if you can possibly make it always select the free repair option then it would be I guess good since the bot is sensing the repair function on it, also note I did this with auto disconnect function off so I don't know if all this was luck or with a purpose...
Reply
#20
It got killed several times and it used free repair option on all tries and revived successfully (for lowers please work on work map function because auto-revive is useless as it continues botting on x-1), anyways I think that the bug is related to the uri repair options which revive the ship on the same spot where it was killed so the bot probably is missing the repair command here, else the bot is running fine no random crashes and no random re-logins.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)